
省*“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
Input测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。Output每个测试用例的输出占一行,输出全省畅通需要的最低成本。Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
Sample Output
3
1
0 这个题目给了路径的条数,所以最好用kruskal
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int maxn=5050;
int n,m,cnt=0; int f[maxn]; struct node
{
int from,to,cost;
node(int from=0,int to=0,int cost=0) : from(from),to(to),cost(cost) {}
}exa[maxn]; void init()
{
for(int i=1;i<=n;i++) f[i]=i;
} int findx(int x)
{
return f[x]==x?x:f[x]=findx(f[x]);//我经常在这里出错!!注意,这里是赋值不是双等号!!!!!
} void unite(int a,int b)
{
int x=findx(a);
int y=findx(b);
if(x==y) return ;
f[x]=y;
} bool same(int x,int y)
{
return findx(x)==findx(y);
} bool cmp(node a,node b)
{
return a.cost<b.cost;
} int kruskal()
{
int res=0;
sort(exa,exa+cnt,cmp);
for(int i=0;i<cnt;i++)
{
if(same(exa[i].from,exa[i].to)) continue;
unite(exa[i].from,exa[i].to);
// printf("%d %d %d\n",exa[i].from,exa[i].to,exa[i].cost);
res+=exa[i].cost;
}
return res;
} int main()
{
while(scanf("%d",&n)!=EOF&&n)
{
cnt=0;
init();
m=n*(n-1)/2;
for(int i=1;i<=m;i++)
{
int a,b,c,d;
scanf("%d%d%d%d",&a,&b,&c,&d);
if(d==1) unite(a,b);
else exa[cnt++]=node(a,b,c);
}
// printf("%d\n",cnt);
printf("%d\n",kruskal());
}
return 0;
}