ACM 最小公倍数

时间:2023-03-08 16:58:11
ACM 最小公倍数
给定两个正整数,计算这两个数的最小公倍数。

Input

输入包含多组测试数据,每组只有一行,包括两个不大于1000的正整数.Output对于每个测试用例,给出这两个数的最小公倍数,每个实例输出一行。 
Sample Input

10 14

Sample Output

70
 #include<bits/stdc++.h>
using namespace std;
int main()
{
int m,n,a,b,c;
while(cin>>a>>b)
{
m = a, n = b;
a = max(m,n);
b = min(m,n);
while(b)
{
c = a % b;
a = b;
b = c;
}
cout<<m*n/a<<endl;
}
return ;
}