杭电 acm 2025 查找最大元素

时间:2021-02-11 11:18:12
查找最大元素
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66002    Accepted Submission(s): 35141






Problem Description


对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。




 




Input


输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。




 




Output


对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。




 




Sample Input


abcdefgfedcba
xxxxx




 




Sample Output


abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)




 




Author


lcy




#include<iostream>#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
char a[100],b[100];
while(cin>>a)
{
int l=strlen(a);
for(int i=0;i<l;i++)
{
b[i]=a[i];
}
sort(b,b+l);
for(int i=0;i<l;i++)
{
if(a[i]==b[l-1]&&i==l-1)
cout<<a[i]<<"(max)"<<endl;
if(a[i]==b[l-1]&&i!=l-1)
cout<<a[i]<<"(max)";
if(a[i]!=b[l-1]&&i==l-1)
cout<<a[i]<<endl;
if(a[i]!=b[l-1]&&i!=l-1)
cout<<a[i];
}
}
return 0;
}