杭电 2025 查找最大元素

时间:2021-10-16 11:18:50

Problem Description 对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
 
Input 输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
 
Output 对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
 
Sample Input
abcdefgfedcba
xxxxx
 
Sample Output
abcdefg(max)fedcba
#include<stdio.h>
#include<string.h>
/*#include<iostream>
#include<algorithm>
using namespace std;*/
int main()
{
char a[1001];
int len,n,i,j;
while(gets(a)!=NULL)
{
len=strlen(a);
char max;
max=a[0];
for(i=1;i<len;i++)
{
if(a[i]>max)
{
max=a[i];
}
}
for(i=0;i<len;i++)
{
if(a[i]==max)
printf("%c(max)",a[i]);
else
printf("%c",a[i]);
}
printf("\n");
}
return 0;
}

x(max)x(max)x(max)x(max)x(max)