杭电OJ2025-查找最大元素

时间:2022-09-01 11:18:30
Problem Description
对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。

Input
输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。

Output
对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。

Sample Input
abcdefgfedcba
xxxxx

Sample Output
abcdefg(max)fedcba

x(max)x(max)x(max)x(max)x(max)



#include<iostream>
#include<cstring>
using namespace std;
int main()
{
char a[100];
int i,max;
while(gets(a))
{
max=a[0];
for(i=0;i<strlen(a);++i)
{
if(max<a[i])
{
max=a[i];
}
}
for(i=0;i<strlen(a);++i)
{
if(max==a[i])
{
cout<<a[i]<<"(max)";
}
else
cout<<a[i];
}
cout<<endl;
}
}



这题我最开始是用string做, Presentation Error了,能得答案,但是格式总不对。想了各种办法,比如insert()……

还是用字符数组做比较方便对每个字符进行处理