【杭电oj2025】查找最大元素

时间:2021-10-16 11:18:56

查找最大元素

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47246    Accepted Submission(s): 25648


Problem Description 对于输入的每个字符串,查找其中的最大字母,在该字母后面插入字符串“(max)”。
 
Input 输入数据包括多个测试实例,每个实例由一行长度不超过100的字符串组成,字符串仅由大小写字母构成。
 
Output 对于每个测试实例输出一行字符串,输出的结果是插入字符串“(max)”后的结果,如果存在多个最大的字母,就在每一个最大字母后面都插入"(max)"。
 
Sample Input
abcdefgfedcba
xxxxx
 
Sample Output
abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)
 
Author lcy  
Source C语言程序设计练习(四)  
Recommend lcy   |   We have carefully selected several similar problems for you:  2072 1251 2044 1008 1161   
Statistic |  Submit |  Discuss |  Note
考察字符串,先遍历一遍找到最大值,然后for循环一次遇到最大值输出max否则按序输出。

#include<stdio.h>
#include<string.h>
int main() {
char c[120],x[7]="(max)",c0;
int i,j;
while(gets(c)) {
c0=c[0];
for(i=0; i<strlen(c); i++) {
if(c[i]>c0)
c0=c[i];
}
for(j=0; j<strlen(c); j++) {
printf("%c",c[j]);
if(c[j]==c0)
printf("%s",x);
}
printf("\n");
}
return 0;
}