CCF计算机软件能力认证试题练习201312-1-出现次数最多的数

时间:2023-01-08 09:01:19

试题编号: 201312-1
试题名称: 出现次数最多的数
时间限制: 1.0s
内存限制: 256.0MB
问题描述:
问题描述
  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s 1, s 2, …, s n (1 ≤ s i ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
样例输出
10

import java.util.Scanner;

/**
* Created by Administrator on 2017/11/15.
*/
public class Main {
public static void main(String[] args) {
new Main().run();
}
void run(){
Scanner scanner=new Scanner(System.in);
int N=scanner.nextInt();
int []count=new int[10001];
for(int i=0;i<N;i++){
int temp=scanner.nextInt();
count[temp]++;
}//输入三次50,那么count[50]的值就为3.
int result=0;
int result2=0;
for(int i=0;i<10001;i++){
if(count[i]>result) {
result = count[i];
result2 = i;
}
}
System.out.println(result2);
}
}