输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式 输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。 样例输入6
10 1 10 20 30 20
样例输出10
根据已给出的参考答案,不懂得地方写了一些备注,新手主要以学习理解为主,主要是思路很关键
import java.util.*;
public class Main {
public static void main(String[] args) {
new Main().run();
}
public void run(){
@SuppressWarnings("resource")
Scanner fin=new Scanner(System.in);
int N=fin.nextInt();//接受第一个整数,也就是即将输入的整数的个数</span>
int[] count=new int[10001];
for(int i=0;i<N;++i){
++count[fin.nextInt()];//等价于int temp = fin.nextInt() count[temp] = count[temp] + 1;
//相当于计算count[10]的数量有几个,以样例为例,count[1]=1,count[10]=2,count[20]=2,count[30]=1. }int maxCount=-1;int result=0;for(int i=0;i<10000;++i){if(count[i]>maxCount){maxCount=count[i];result=i;}}System.out.println(result);}}