CCF系列之Z字形扫描(201412-2)

时间:2022-06-18 15:43:26
试题编号:201412-2
试题名称:Z字形扫描
时间限制: 2.0s
内存限制: 256.0MB
问题描述
  在图像编码的算法中,需要将一个给定的方形矩阵进行Z字形扫描(Zigzag Scan)。给定一个n×n的矩阵,Z字形扫描的过程如下图所示:
  CCF系列之Z字形扫描(201412-2)
  对于下面的4×4的矩阵,
  1 5 3 9
  3 7 5 6
  9 4 6 4
  7 3 1 3
  对其进行Z字形扫描后得到长度为16的序列:
  1 5 3 9 7 3 9 5 4 7 3 6 6 4 1 3
  请实现一个Z字形扫描的程序,给定一个n×n的矩阵,输出对这个矩阵进行Z字形扫描的结果。
输入格式
  输入的第一行包含一个整数n,表示矩阵的大小。
  输入的第二行到第n+1行每行包含n个正整数,由空格分隔,表示给定的矩阵。
输出格式
  输出一行,包含n×n个整数,由空格分隔,表示输入的矩阵经过Z字形扫描后的结果。
样例输入
4
1 5 3 9
3 7 5 6
9 4 6 4
7 3 1 3
样例输出
1 5 3 9 7 3 9 5 4 7 3 6 6 4 1 3
评测用例规模与约定
  1≤n≤500,矩阵元素为不超过1000的正整数。
解题思路:
CCF系列之Z字形扫描(201412-2)
CCF系列之Z字形扫描(201412-2)
CCF系列之Z字形扫描(201412-2)
CCF系列之Z字形扫描(201412-2)
CCF系列之Z字形扫描(201412-2)
CCF系列之Z字形扫描(201412-2)
实现代码自己写的(java):
  
 import java.util.Scanner;

 public class Main {
public static void main(String[] args) { Scanner sc=new Scanner(System.in); int n=sc.nextInt(); sc.nextLine(); int num = n + 1; int[][] matrix=new int[num][num]; for (int i = 1; i < num; i++) { for (int j = 1; j < num; j++) { matrix[i][j]=sc.nextInt();
}
sc.nextLine();
}
printIt(matrix);
} public static void printIt(int[][]arr){ int n = arr.length; n--; for(int i = 1; i<=n; i++){ if(i%2 == 1){ int k = 1; for(int j = i; j>0;j--){ System.out.print(arr[j][k++]+" ");
} }else{ int k = i; for(int j = 1; j<=i;j++){ System.out.print(arr[j][k--]+" ");
}
}
} for(int i = n-1; i>0; i--){ if(i%2 == 0){ int k = n; for(int j = n-i+1; j<=n;j++){ System.out.print(arr[j][k--]+" ");
} }else{ int k = n-i+1; for(int j = n; j>=n-i+1;j--){ System.out.print(arr[j][k++]+" ");
}
}
}
} }

运行结果:

  CCF系列之Z字形扫描(201412-2)

实现代码2 别人写的(java):

  

 import java.util.Scanner;

 public class Main {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
int n;
n=sc.nextInt();
int[][] matrix=new int[n][n];
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
matrix[i][j]=sc.nextInt();
}
} for (int i = 0; i < n; i++) {
int row=0;
int column=0;
if (i%2==0) {
row=i;
column=0;
System.out.print(matrix[row][column]+" ");
while (row-1>=0&&column+1<n) {
row--;
column++;
System.out.print(matrix[row][column]+" ");
}
} else {
row=0;
column=i;
System.out.print(matrix[row][column]+" ");
while (row+1<n&&column-1>=0) {
row++;
column--;
System.out.print(matrix[row][column]+" ");
}
}
}
for (int i = 1; i <n ; i++) {
int row=0;
int column=0;
if(n%2!=0){
if (i%2==0) {
row=n-1;
column=i;
System.out.print(matrix[row][column]+" ");
while (row-1>=0&&column+1<n) {
row--;
column++;
System.out.print(matrix[row][column]+" ");
}
} else {
row=i;
column=n-1;
System.out.print(matrix[row][column]+" ");
while (row+1<n&&column-1>=0) {
row++;
column--;
System.out.print(matrix[row][column]+" ");
}
}
} else {
if (i%2==0) {
row=i;
column=n-1;
System.out.print(matrix[row][column]+" ");
while (row+1<n&&column-1>=0) {
row++;
column--;
System.out.print(matrix[row][column]+" ");
} } else {
row=n-1;
column=i;
System.out.print(matrix[row][column]+" ");
while (row-1>=0&&column+1<n) {
row--;
column++;
System.out.print(matrix[row][column]+" ");
}
}
} }
} }

运行结果:

  CCF系列之Z字形扫描(201412-2)