杭电1695 GCD(莫比乌斯反演)

时间:2022-09-19 05:16:32

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6247    Accepted Submission(s): 2289


Problem Description Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 
Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 
Output For each test case, print the number of choices. Use the format in the example.
 
Sample Input
2
1 3 1 5 1
1 11014 1 14409 9
 
Sample Output
Case 1: 9
Case 2: 736427

HintFor the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
 
Source 2008 “Sunline Cup” National Invitational Contest 
/*
31ms比容斥原理快多了,,,之前用容斥做过,两天没白搞,,不过代码还是猥琐的看的bin神的代码。。。。。加油!!!
Time:2014-12-28 0:26
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=100000+10;
bool vis[MAX+10];
int mu[MAX+10],prime[MAX];
typedef long long LL;
void mobius(){//线性筛法求顺便mu
mu[1]=1;int tot=0;
memset(vis,0,sizeof(vis));
for(int i=2;i<=MAX;i++){
if(!vis[i]){
prime[tot++]=i;
mu[i]=-1;
}
for(int j=0;j<tot;j++){
if(i*prime[j]>MAX) break;
vis[i*prime[j]]=true;
if(i%prime[j]==0){
mu[i*prime[j]]=0;
break;
}else{
mu[i*prime[j]]=-mu[i];
}
}
}
}
int main(){
int T;
mobius();//打表
int a,b,c,d,k;
int nCase=0;
scanf("%d",&T);
while(T--){
nCase++;
scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);//求1---b与1---d内最大公约数是k的个数,相当于求1---b/k与1---d/k之间互质的个数
if(k==0){
printf("Case %d: 0\n",nCase);
continue;
}
b/=k;d/=k;
if(b>d)swap(b,d);
LL ans=0;
for(int i=1;i<=b;i++)//1--b与1--d互质的个数
ans+=(LL)mu[i]*(b/i)*(d/i);
LL more=0;
for(int i=1;i<=b;i++)//1--b与1--b互质的个数
more+=(LL)mu[i]*(b/i)*(b/i);
ans-=(more>>1);//题目要求5 7 和7 5是一组,刚好减去一半即可
printf("Case %d: %lld\n",nCase,ans);
}
return 0;
}