PAT Basic 1048

时间:2020-12-28 10:01:59
1048 数字加密

本题要求实现一种数字加密方法。首先固定一个加密用正整数 A,对任一正整数 B,将其每 1 位数字与 A 的对应位置上的数字进行以下运算:对奇数位,对应位的数字相加后对 13 取余——这里用 J 代表 10、Q 代表 11、K 代表 12;对偶数位,用 B 的数字减去 A 的数字,若结果为负数,则再加 10。这里令个位为第 1 位。

输入格式:

输入在一行中依次给出 A 和 B,均为不超过 100 位的正整数,其间以空格分隔。

输出格式:

在一行中输出加密后的结果。

输入样例:

1234567 368782971

输出样例:

3695Q8118

  题解:按照题意,直接写就好O(∩_∩)O~
代码如下:
 #include<iostream>
#include<string>
#include<cmath>
using namespace std; int main()
{
string a, b, c;
cin>>a>>b;
int l = ;
while( a.length() > b.length()){
b = ''+ b;
}
while( a.length() < b.length() ){
a = '' + a;
}
for(int i = a.length() - ; i >= ; i--,l++){
if(l%==){
int temp = (a[i] - '' + b[i] - '') % ;
if( temp < ){
char d = temp + '';
c = d + c;
}
else if( temp == )
c = 'J' + c;
else if( temp == )
c = 'Q' + c;
else if( temp == )
c = 'K' + c;
}
else{
int temp = b[i] - a[i];
if(temp < ) temp += ;
char d = temp + '';
c = d + c;
}
}
cout<<c;
return ;
}