hdu 2899 Strange fuction

时间:2021-06-03 05:49:56

http://acm.hdu.edu.cn/showproblem.php?pid=2899

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4865    Accepted Submission(s): 3468

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 
Sample Input
2
100
200
 
Sample Output
-74.4291
-178.8534
 

二分搜索+求导

对函数进行求导,导数为0时,x的值是函数值最小

导数小于0函数递减,导数大于0函数递增

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#define N 1010
#define INF 0x3f3f3f3f using namespace std; int main()
{
int t;
double y, f, f1;
scanf("%d", &t);
while(t--)
{
scanf("%lf", &y);
double mid, low = , high = ;
while(high - low > 1e-)/***此处注意*/
{
mid = (low + high) / ;
f1 = * pow(mid, ) + * pow(mid, ) + * pow(mid, ) + * mid;//导数
if(f1 < y)
low = mid;
else if(f1 == y)
break;
else
high = mid;
}
f = * pow(mid, ) + * pow(mid, ) + * pow(mid, ) + * pow(mid, ) - mid * y;
printf("%.4f\n", f);
}
return ;
}