请问当小明的蛋糕分完时,总共有多少个朋友分到了蛋糕。 输入格式 输入的第一行包含了两个整数n, k,意义如上所述。
第二行包含n个正整数,依次表示a1, a2, …, an。 输出格式 输出一个整数,表示有多少个朋友分到了蛋糕。 样例输入 6 9
2 6 5 6 3 5 样例输出 3 样例说明 第一个朋友分到了前3块蛋糕,第二个朋友分到了第4、5块蛋糕,第三个朋友分到了最后一块蛋糕。 评测用例规模与约定
对于所有评测用例,1 ≤ n ≤ 1000,1 ≤ k ≤ 10000,1 ≤ ai ≤ 1000。
这个题比较简单,直接上代码就可以了。
import java.util.*;
public class Cake {
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in = new Scanner(System.in);
int friends = in.nextInt();
int weight = in.nextInt();
int nums = 1;
int now = 0;
for(int i = 0;i<friends;i++){
now += in.nextInt();
if(now >= weight && i<friends-1){
nums++;
now = 0;
}
}
System.out.println(nums);
}
}
本机eclipse测试截图如下:
CCF官网测试结果如下