The more, The Better
时限:2000ms
Problem Description ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物。但由于地理位置原因,有些城堡不能直接攻克,要攻克这些城堡必须先攻克其他某一个特定的城堡。你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗? Input 每个测试实例首先包括2个整数,N,M.(1 <= M <= N <= 200);在接下来的N行里,每行包括2个整数,a,b. 在第 i 行,a 代表要攻克第 i 个城堡必须先攻克第 a 个城堡,如果 a = 0 则代表可以直接攻克第 i 个城堡。b 代表第 i 个城堡的宝物数量, b >= 0。当N = 0, M = 0输入结束。 Output 对于每个测试实例,输出一个整数,代表ACboy攻克M个城堡所获得的最多宝物的数量。 Sample Input 3 20 10 20 37 42 20 10 42 17 17 62 20 0 Sample Output 5 13从节点0出发,找到经过m个节点的最长链,实际上是m+1个节点,因为每次都要从0节点开始。从树的下面开始dp。
dp[u][w]表示在u的子树上选择w个节点,u节点是必选的。
我开始比较纠结的是最长的链会不会被多次使用,纠结了一会发现不会的,方程dp[u][w] = max(dp[u][w], dp[u][w - k] + dp[v][k] + val[v]);中,dp[u][w-k]始终是先被访问,dp[u][w]后被访问,在一个子树上dp的时候不会被更新并访问的。
#include "bits/stdc++.h"View Code
using namespace std;
const int maxn = 300;
int n, m;
int dp[maxn][maxn];
struct edge {
int to, next;
} e[maxn];
int head[maxn];
int val[maxn];
int tot = 0;
void add_edge(int u, int v) {
e[tot].to = v;
e[tot].next = head[u];
head[u] = tot++;
}
void dfs(int u) {
for (int i = head[u]; i != -1; i = e[i].next) {
int v = e[i].to;
dfs(v);
for (int w = m + 1; w > 0; w--) {
for (int k = 1; k < w; k++) {
dp[u][w] = max(dp[u][w], dp[u][w - k] + dp[v][k] + val[v]);
}
}
}
}
void init() {
tot = 0;
memset(head, -1, sizeof(head));
memset(dp, 0, sizeof(dp));
}
int main(int argc, char const *argv[])
{
while (scanf("%d%d", &n, &m) ,n) {
init();
for (int i = 1; i <= n; i++) {
int a, b;
scanf("%d%d", &a, &b); val[i] = b;
add_edge(a, i);
}
dfs(0);
printf("%d\n", dp[0][m + 1]);
}
return 0;
}