数据结构实验之二叉树的建立与遍历

时间:2021-07-16 10:31:04

数据结构实验之二叉树的建立与遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

输入

 输入一个长度小于50个字符的字符串。

输出

输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。

示例输入

abc,,de,g,,f,,,

示例输出

cbegdfacgefdba35

提示

 

来源

 ma6174

示例程序

 

#include <stdio.h>

#include <stdlib.h>
#include <string.h>
typedef struct node
{
int num;
struct node *l,*r;
}node,*tree;
char a[100];
int i;
int mount,deepv;
tree creat()
{
tree t;
char ch;
ch=a[i];
i++;
if(ch==',')
{
        t=NULL;
}
else
{
t=(tree)malloc(sizeof(node));
t->num=ch;
t->l=creat();
t->r=creat();
}
return t;
}
void zhong(tree t)
{
if(t!=NULL)
{
zhong(t->l);
printf("%c",t->num);
zhong(t->r);
}
}
void hou(tree t)
{
if(t!=NULL)
{
hou(t->l);
hou(t->r);
   printf("%c",t->num);
}
}
void leaf(tree t)
{

if(t!=NULL)
{
  if(t->l==NULL&&t->r==NULL)
  {
         mount++;
  }
  leaf(t->l);
  leaf(t->r);
}
   
}


int deep(tree t)
{
int deepl,deepr;
if(t==NULL)
{
deepv=0;
// return 0;
}
else
{
deepl=deep(t->l);
deepr=deep(t->r);
deepv=1+(deepl>deepr?deepl:deepr);
}


return deepv;
}
int main()
{
tree t;
int n;
gets(a);

i=0;
t=creat();
mount=0;
    zhong(t);
printf("\n");
hou(t);
printf("\n");
leaf(t);
printf("%d\n",mount);
deepv=0;
n=deep(t);
printf("%d\n",n);


return 0;
}