蓝桥杯 算法训练 5-1最小公倍数

时间:2022-08-04 00:30:27
算法训练 5-1最小公倍数  
时间限制:1.0s   内存限制:256.0MB
    
问题描述
  编写一函数lcm,求两个正整数的最小公倍数。
样例输入
一个满足题目要求的输入范例。
例:

3 5
样例输出
与上面的样例输入对应的输出。
例:
蓝桥杯 算法训练 5-1最小公倍数
数据规模和约定
  输入数据中每一个数的范围。
   例:两个数都小于65536。
辗转相除法就最小公倍数。
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
int a,b,temp;
scanf("%d %d",&a,&b);
if(a<b)
{
temp=a;
a=b;
b=temp;
}
int n1=a;
int n2=b;
while(n2!=0)
{
temp=n1%n2;
n1=n2;
n2=temp;
}//最后的n1为两数的最大公约数
printf("%d\n",a*b/n1);
return 0;
}