Problem Description
Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
给出两个数字组成的序列a,b,求b在a的哪个位置开始能完全匹配,有多个输出最小的
对KMP算法稍微一改,如果匹配串能够遍历完,则直接返回当前原串的位置,而不是记录下个数
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <ctime>
#define INF 0x3f3f3f3f
#define MAXN 10005
#define Mod 1000000007
using namespace std;
int a[MAXN*100],b[MAXN];
int nextb[MAXN],n,m;
void getnext()
{
int i=0,j=-1;
nextb[0]=-1;
while(i<m)
{
if(j==-1||b[i]==b[j])
{
i++;
j++;
nextb[i]=j;
}
else
j=nextb[j];
}
}
int kmp()
{
int i=0,j=0;
while(i<n)
{
if(j==-1||a[i]==b[j])
{
i++;
j++;
}
else
j=nextb[j];
if(j==m)
return i;
}
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;++i)
scanf("%d",&a[i]);
for(int i=0;i<m;++i)
scanf("%d",&b[i]);
getnext();
int ans=kmp();
if(ans==-1)
printf("%d\n",ans);
else
printf("%d\n",ans-m+1);
}
return 0;
}