CSU1979: 古怪的行列式
Description
这几天,子浩君潜心研究线性代数。 行列式的值定义如下:
其中,τ(j1j2...jn)为排列j1j2...jn的逆序数。
子浩君很厉害的,但是头脑经常短路,所以他会按照行列式值的定义去计算,这个行列式子浩君也还是能算对的。但是,在计算的过程中,如果出现连续三行选取的元素为83(S),83(S),82(R)的话,子浩君会忍不住拿走它们:-D,然后这三个数的乘积将被视为1,而其它数值计算不变。那么在子浩君的计算下,最后得到的行列式的值会为多少呢?
Input
数据第一行为一个整数T(T<=50)。 接下来有T组测试数据,每组数据开始有一个整数n(2<=n<=8)。 接下来有n行数字,每行有n个数字,第ith行第jth个数字代表矩阵的第ith行第jth列的数字,保证每个数字在int范围内的非负整数。
Output
输出一个整数,保证在[-(2^63-1), 2^63-1]范围内,即使在子浩君计算过程中也是。
Sample Input
4
2
1 1
0 1
3
83 1 1
0 83 1
0 0 82
3
83 1 1
0 82 1
0 0 83
3
83 1 1
0 83 1
0 1 82
Sample Output
1
1
564898
-82
Hint
例如,当子浩君遇到a11 * a22 * a33 * a44 = 83 * 83 * 82 * 1,会计算成1 * 1 = 1,而83 * 82 * 83 * 1或者83 * 83 * 1 * 82则不会改变运算规则
Source
2017年8月月赛
Author
李子浩
行列式较小,故直接通过next_permutation()获得全排列,枚举所有的排列情况来计算行列式的值。运算中检查是否在连续的三行中按给定顺序取出了‘S’‘S’‘R’的ASCII码值,若某次运算出现了这种情况,即用本次计算结果除该三数的乘积得到本次计算的最终结果,将数次计算得到的值相加,得到行列式的值。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef long long ll;
using namespace std;
const int maxn = 10;
int T, n;
ll myints[] = {0,1,2,3,4,5,6,7}, sample[maxn][maxn];
ll checkSgn(){ // 计算逆序数。
int cnt = 0;
for(int i = 0; i < n-1; i++)
for(int j = i+1; j < n; j++)
if(myints[j] < myints[i])
cnt++;
if(cnt & 1)
return -1;
return 1;
}
int main(){
#ifdef TEST
freopen("test.txt", "r", stdin);
#endif // TEST
cin >> T;
while(T--){
cin >> n;
for(int i = 0; i < n; i++)
for(int j = 0; j < n; j++)
cin >> sample[i][j];
ll res = 0;
do{
ll temp = 1;
for(int i = 0; i < n; i++){
temp *= sample[i][myints[i]];
if(i >= 2)
if(sample[i][myints[i]] == 82 && sample[i-1][myints[i-1]] == 83 && sample[i-2][myints[i-2]] == 83){
temp /= (82*83*83);
}
}
temp *= checkSgn(); // 将一次排列得出的结果乘上1或-1.
res += temp;
}while(next_permutation(myints, myints+n));
cout << res << endl;
}
return 0;
}