线段树--Color the ball(多次染色问题)

时间:2022-11-07 17:59:52
K - Color the ball

Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。 

当N = 0,输入结束。
 

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input

3
1 1
2 2
3 3
3
1 1
1 2
1 3
0
 

Sample Output

1 1 1
3 2 1
 

中文题你懂的;

一看到这道题我就想做线段树,好快写出来了,可是尼玛各种bug啊卧槽,后来搞了好久才解决 待会说下我的问题;唉还是太弱了;

struct Tree{
int type;
int po;
}tree[maxn<<2];

po用来记录该节点是否被走过,type用来记录当前节点存储了多少颜色这里采用懒惰标记,当然 如果要往子节点继续找的话,懒惰标记下移,po=1表示被走过;

具体看代码;

在正常的update之后;还要把节点信息继续下移;下移的条件是,该节点被走过,也就是说子节点或更下面的节点有值,要更新到没被走过的那个节点;

具体看 newupdate函数;

void newupdate(int L,int R,int l,int r,int rt){

	if(tree[rt].po==false)return;
if(tree[rt].type>0){
PushDown(rt);
}
int m = (l + r) >> 1; // 而如果你是要更新[1,1](必定访问到标记2) 那么先进行标记2 让两儿子的value更新
if (L <= m) newupdate(L , R , lson); //记得这时候儿子type被赋值,自己type=0;
if (R > m) newupdate(L , R , rson); }

最后用一个query函数来输出,输出的条件是当前节点的type>0 因为我们之前已经往下更新了;

最后记住输出的问题,我这里定义了一个全局变量first;初始化0只要准备输出之前让它++;只有first==1的时候输出type,不然前面要多输出一个空格

具体看代码

不过我这个程序居然跑了1400ms 感觉不够快,希望大牛们能够给予指点

#include <iostream>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
#define LL long long
const int maxn = 111111;
int first;
struct Tree{ int type;
int po;
}tree[maxn<<2]; void PushDown(int rt) {
if (tree[rt].type) {
tree[rt<<1].type += tree[rt].type;
tree[rt<<1|1].type += tree[rt].type ;
tree[rt].type = 0;
}
tree[rt].po=1;
}
void build(int l,int r,int rt) {
tree[rt].po=0;
tree[rt].type=0;
if (l == r){
return ;
}
int m = (l + r) >> 1;
build(lson);
build(rson);
}
void update(int L,int R,int c,int l,int r,int rt) {//(L,R)是我们要找的范围
if (L <= l && r <= R) {//标记1 //更新到这就行,不一定更新到最底端
tree[rt].type += c;
// tree[rt].value += c;
return ;
}
PushDown(rt );//延迟标记,这时候后推, (标记2)
int m = (l + r) >> 1;
if (L <= m) update(L , R , c , lson);
if (R > m) update(L , R , c , rson);
}
void newupdate(int L,int R,int l,int r,int rt){ if(tree[rt].po==false)return;
if(tree[rt].type>0){
PushDown(rt);
}
int m = (l + r) >> 1; // 而如果你是要更新[1,1](必定访问到标记2) 那么先进行标记2 让两儿子的value更新
if (L <= m) newupdate(L , R , lson); //记得这时候儿子type被赋值,自己type=0;
if (R > m) newupdate(L , R , rson); }
void query(int L,int R,int l,int r,int rt) {
if(tree[rt].type>0){
for(int i=l;i<=r;i++){
first++;
if(first==1)cout<<tree[rt].type; //输出的处理
else
cout<<" "<<tree[rt].type; //输出的处理
}
}
else if(l==r&&tree[rt].type==0){
first++; //输出的处理
if(l==1)cout<<"0"; //输出的处理
else //输出的处理
cout<<" 0";} //输出的处理
else{
int m = (l + r) >> 1;
if (L <= m) query(L , R , lson);
if (R > m) query(L , R , rson);
}
}
int main() {
int n;int a,b;
while(cin>>n){
if(n==0)break;
first=0;
build( 1, n, 1);
for(int i=1;i<=n;i++){
cin>>a>>b;
update(a,b,1,1,n,1); }
newupdate(1,n,1,n,1); query(1,n,1,n,1);
cout<<endl; }
return 0;
}
/*
*
6
1 2
3 4
1 4
2 4
3 5
2 2
2 4 4 4 1 0
*/

版权声明:本文为博主原创文章,未经博主允许不得转载。

线段树--Color the ball(多次染色问题)的更多相关文章

  1. HDU 1556 Color the ball&lpar;线段树区间更新&rpar;

    Color the ball 我真的该认真的复习一下以前没懂的知识了,今天看了一下线段树,以前只会用模板,现在看懂了之后,发现还有这么多巧妙的地方,好厉害啊 所以就应该尽量搞懂 弄明白每个知识点 [题 ...

  2. hdu 1556&colon;Color the ball(线段树,区间更新,经典题)

    Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)To ...

  3. POJ 2777 Count Color(线段树染色,二进制优化)

    Count Color Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 42940   Accepted: 13011 Des ...

  4. hdoj 1556 Color the ball【线段树区间更新】

    Color the ball Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)To ...

  5. hdu 1199 Color the Ball&lpar;离散化线段树&rpar;

    Color the Ball Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) T ...

  6. POJ训练计划2777&lowbar;Count Color&lpar;线段树&sol;成段更新&sol;区间染色&rpar;

    解题报告 题意: 对线段染色.询问线段区间的颜色种数. 思路: 本来直接在线段树上染色,lz标记颜色.每次查询的话訪问线段树,求出颜色种数.结果超时了,最坏的情况下,染色能够染到叶子节点. 换成存下区 ...

  7. Color the ball&lpar;树状数组&plus;线段树&plus;二分&rpar;

    Color the ball Time Limit : 9000/3000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other) Tota ...

  8. Color the ball(hdu1556)(hash)或(线段树,区间更新)

    Color the ball Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total ...

  9. POJ-2777 Count Color(线段树,区间染色问题)

    Count Color Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 40510 Accepted: 12215 Descrip ...

随机推荐

  1. Android 学习第4课,一些小知识

    java语言的注释有如下3种: 1. // 2./* 注释内容 */ 3./**     注释内容    */       这种叫文档注释,这种注释常被javaDoc文档工具读取作为 JavaDoc文 ...

  2. php函数:PHP pathinfo&lpar;&rpar; 函数

    pathinfo() 函数以数组的形式返回文件路径的信息. 语法 pathinfo(path,options) 参数 描述 path 必需.规定要检查的路径. process_sections 可选. ...

  3. java语法体系

    乱写的不具备参考性,只是一个备忘录

  4. ubuntu不能正常使用make menuconfig的解决方案

    so easy sudo apt-get install build-essentialsudo apt-get install libncurses5sudo apt-get install lib ...

  5. 如何打开Windows Server 2003 内存寻址扩展

    本文介绍了如何在系统内存大于4G的情况下,让windows2003 Advanced Server支持大内存的方法: 由于Windows2003 32bit是32位操作系统,当服务器配备内存高达4G时 ...

  6. iOS iOS9下修改回HTTP模式进行网络请求

    升级为iOS9后,默认请求类型为https,如何使用http进行请求会报错 The resource could not be loaded because the App Transport Sec ...

  7. 记录linux配置

    只写成功过程:1.配置sshd: 首先开启安全组端口,选择合适端口(tcp),shell输入vi /etc/services ->ssh修改(21变更为合适端口) 接着shell输入vi /et ...

  8. 2&period; Spring 的 HelloWorld

    初学Spring,就先来写一个 Spring 的 HelloWorld 吧 1. 首先,新建一个 java Project(因为暂时不需要网页,所以就不用创建 web 项目了) 2. 导入 Sprin ...

  9. leetcode 93 复原IP地址

    IP地址,分成四段,每段是0-255,按照每段的长度分别为1,2,3下一段长度分别1,2,3再下一段......进行递归遍历,能满足条件的假如res中.比较难想到的就是假如有一段是三位的010是不符合 ...

  10. 逆袭之旅DAY16&period;东软实训&period;Oracle&period;匿名块

    2018-07-1216:41:19 六.匿名块 .定义匿名块: declare 定义部分: ---可选部分 begin 执行部分: ---必选部分 exception 异常处理部分: ---可选部分 ...