试题名称: 出现次数最多的数
时间限制: 1.0s
内存限制: 256.0MB
问题描述:
问题描述
给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。
输入格式
输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。
输出格式
输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。
样例输入
6
10 1 10 20 30 20
样例输出
10
#include<iostream>
#include<stdio.h>
#include<map>
using namespace std;
int main()
{
typedef map<int,int> intIntMap;
intIntMap iter;
int n;
cin>>n;
int max=0,max_num=0;
int a;
while(n--)
{
cin>>a;
iter[a]++;
}
for(intIntMap::iterator pos=iter.begin();pos!=iter.end();pos++)
{
if(pos->second>max||pos->second==max&&pos->first<max_num)
{
max=pos->second;
max_num=pos->first;
}
}
cout<<max_num<<endl;
return 0;
}