1048. 数字加密(20)
本题要求实现一种数字加密方法。首先固定一个加密用正整数A,对任一正整数B,将其每1位数字与A的对应位置上的数字进行以下运算:对奇数位,对应位的数字相加后对13取余——这里用J代表10、Q代表11、K代表12;对偶数位,用B的数字减去A的数字,若结果为负数,则再加10。这里令个位为第1位。
输入格式:
输入在一行中依次给出A和B,均为不超过100位的正整数,其间以空格分隔。
输出格式:
在一行中输出加密后的结果。
输入样例:
1234567 368782971
输出样例:
3695Q8118
注意:A,B两串的字符串不一定等长
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
int main()
{
string a, b;
string ans = "";
cin >> a >> b;
int lenA = a.length();
int lenB = b.length();
int len = (lenA > lenB) ? lenA : lenB;
if (lenA < lenB)
{
for (int i = 0; i < lenB - lenA; i++)
{
a = "0" + a;
}
}
if (lenA >lenB)
{
for (int i = 0; i < lenA - lenB; i++)
{
b = "0" + b;
}
}
int cnt = 1;
for (int i = len - 1; i >= 0; i--)
{
if (cnt % 2 == 1)
{
int temp = (b[i]-'0' + a[i]-'0') % 13;
if (temp < 10)
ans = (char)(temp + '0') + ans;
else if (temp == 10)
ans = 'J' + ans;
else if (temp == 11)
ans = 'Q' + ans;
else if (temp == 12)
ans = 'K' + ans;
}
else
{
int temp2 = b[i] - '0' - (a[i] - '0');
if (temp2 >= 0)
ans = (char)(temp2 + '0') + ans;
else
ans = (char)(temp2 + 10+'0') + ans;
}
cnt++;
}
for (int i = 0; i < len; i++)
cout << ans[i];
//cout << a << " " << b;
system("pause");
return 0;
}