接下来n行,每行m个数,数之间没有间隔,为0或1中的一个。0表示这个格子可以通过,1表示不可以。假设你现在已经在迷宫坐标(1,1)的地方,即左上角,迷宫的出口在(n,m)。每次移动时只能向上下左右4个方向移动到另外一个可以通过的格子里,每次移动算一步。数据保证(1,1),(n,m)可以通过。 输出格式 第一行一个数为需要的最少步数K。
第二行K个字符,每个字符∈{U,D,L,R},分别表示上下左右。如果有多条长度相同的最短路径,选择在此表示方法下字典序最小的一个。 样例输入 Input Sample 1:
3 3
001
100
110
Input Sample 2:
3 3
000
000
000 样例输出 Output Sample 1:
4
RDRD
Output Sample 2:
4
DDRR 数据规模和约定 有20%的数据满足:1<=n,m<=10
有50%的数据满足:1<=n,m<=50
有100%的数据满足:1<=n,m<=500。
直接用广搜就行,要注意的就是路径的存储
如果有多条长度相同的最短路径,选择在此表示方法下字典序最小的一个
不如直接先把上下左右按照字典序排列,在遍历迷宫的同时就按照DLRU的顺序遍历
最后得到的也就是最短路径和字典序最小的最短路径
#include<iostream>
#include<algorithm>
#include<set>
#include<cmath>
#include<stack>
#include<string>
#include<queue>
using namespace std;
char map[500+5][500+5];
int v[500+5][500+5]={0};
int a[4][2]={1,0,
0,-1,
0,1,
-1,0};
int n,m;
struct node{
int x,y,len;
string str;
};
int pd(int x,int y){
if(x<0||y<0||x>=n||y>=m||map[x][y]=='1'||v[x][y]==1) return 0;
return 1;
}
void bfs(){
queue<node> que;
node n1;
n1.x=0;
n1.y=0;
n1.len=0;
que.push(n1);
string str="";
while(que.size()){
node no=que.front();
que.pop();
if(no.x==n-1&&no.y==m-1){
cout<<no.len<<endl;
cout<<no.str;
break;
}
for(int i=0;i<4;i++){
int xx=no.x+a[i][0];
int yy=no.y+a[i][1];
if(pd(xx,yy)){
v[xx][yy]=1;
node n2;
n2.x=xx;
n2.y=yy;
n2.len=no.len+1;
if(i==0) n2.str=no.str+"D";
if(i==1) n2.str=no.str+"L";
if(i==2) n2.str=no.str+"R";
if(i==3) n2.str=no.str+"U";
que.push(n2);
}
}
}
}
int main(){
cin>>n>>m;
//char s[500+5][500+5];
for(int i=0;i<n;i++){
for(int j=0;j<m;j++)
cin>>map[i][j];
}
bfs();
return 0;
}