【CSU 1803】2016 (数学)

时间:2021-07-26 20:09:58

Description

给出正整数 n 和 m,统计满足以下条件的正整数对 (a,b) 的数量:

1. 1≤a≤n,1≤b≤m;

2. a×b 是 2016 的倍数。

Input

输入包含不超过 30 组数据。
每组数据包含两个整数 n,m (1≤n,m≤109).

Output

对于每组数据,输出一个整数表示满足条件的数量。

Sample Input

32 63
2016 2016
1000000000 1000000000

Sample Output

1
30576
7523146895502644
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdio>
#include<string>
#include<bitset>
#include<cstdio>
#include<vector>
#include<sstream>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
typedef long long ll;
typedef pair<int,int> pii;
typedef pair<string,int>psi;

int main()
 {
    int n,m,nn,mm,i,j;
    while(~scanf("%d%d",&n,&m))
    {
        ll ans=;
        ;i<=min(n,);++i)
            ;j<=min(m,);++j)
                ==)
                    ans+=1LL*((n-i)/+)*((m-j)/+);
        printf("%lld\n", ans);
    }
    ;
}