HDU 2594 两串合为一串,利用nex数组巧解

时间:2021-08-08 19:11:12

http://acm.hdu.edu.cn/showproblem.php?pid=2594

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9102    Accepted Submission(s): 3151


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
 
 
clintonhomerriemannmarjorie
 

Sample Output
 
 
0rie 3
题意:在第一个串里找个前缀,在第二个串里找个后缀,使得这两个缀相同,输出这个缀,和长度

思路:先把两个串合成一个串,然后求出新串的nex数组,只是nex数组求法稍作修改即可,

注意1:nex的值不可以大于第一个串的长度。若大于则执行x=nex[x];   (细细品味)

2:第二个串的第一个字母一定要从第一个串的第一个字母开始匹配。if(y==la) x=0;

上面的两条跟下面的样例是对应的。其他的东西跟就模板一样了。

样例:

Sample Input

aaba

abaabaa

abcabc

abc

Sample Output

aa 2

abc 3

不说了,上AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#define maxx 50500
using namespace std;
char a[maxx*2];
int nex[maxx*2];
int la,lb;
void prekmp()
{
int x=-1,y=0;
nex[0]=-1;
while(y<lb)
{
if(y==la) x=0;
while((x!=-1&&a[x]!=a[y])||x>=la)
x=nex[x];
nex[++y]=++x;
}
}
int main()
{
while(~scanf("%s",a))
{
la=strlen(a);
scanf("%s",a+la);
lb=strlen(a);
prekmp();
for(int i=0;i<nex[lb];i++)
printf("%c",a[i]);
if(nex[lb]) printf(" ");
printf("%d\n",nex[lb]);
}
}