
F - 简单计算器
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
Sample Output
3.00
13.36
//难了我很久,后来学习了栈,用一个栈就很简单啦。例如4 + 2 * 5 - 7 / 11,把4放入栈,把2*5的值放入栈,把-7/10的值放入栈,最后依次全部取出,计算总和。
#include <iostream>
#include <stack>
#include <stdio.h>
using namespace std; int main()
{
double num1;
char ch;
while (cin>>num1)
{
stack<double> data;
ch=getchar();
if (num1==&&ch=='\n')
{
break;
}//结束 double num2;
while (cin>>ch)
{
if (ch=='+'||ch=='-')
{
cin>>num2;
if (ch=='-') num2=-num2;
data.push(num1);
num1=num2;
ch=getchar();
if (ch=='\n')
{
data.push(num1);
break;
}
}
if (ch=='*'||ch=='/')
{
cin>>num2;
if(ch=='*')
{
num1*=num2;
ch=getchar();
if (ch=='\n')
{
data.push(num1);
break;
}
}
if (ch=='/')
{
num1/=num2;
ch=getchar();
if (ch=='\n')
{
data.push(num1);
break;
}
}
}
}
double ans=;
while (!data.empty())
{
ans+=data.top();
data.pop();
}
printf("%.2lf\n",ans);
}
return ;
}