给出2个数M和N(M < N),且M与N互质,找出一个数K满足0 < K < N且K * M % N = 1,如果有多个满足条件的,输出最小的。
Input
输入2个数M, N中间用空格分隔(1 <= M < N <= 10^9)
Output
输出一个数K,满足0 < K < N且K * M % N = 1,如果有多个满足条件的,输出最小的。
Sample Input
2 3
Sample Output
2
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<stack>
#include<deque>
#include<iostream>
using namespace std;
typedef long long LL;
void ex_gcd(LL a,LL b,LL &x,LL &y,LL &d)
{
if(!b) {x = ,y = ,d = a;}
else
{
ex_gcd(b,a%b,y,x,d);
y -= x * (a / b);
}
}
LL inv(LL a,LL b)
{
LL x,y,d;
ex_gcd(a,b,x,y,d);
return d == ?((x % b) + b)%b : -;
}
int main()
{
LL n,m;
int i,p,j;
scanf("%lld%lld",&m,&n);
printf("%lld\n",inv(m,n));
return ;
}