POJ 1325-Machine Schedule(二分图_最大匹配最小点覆盖)

时间:2022-02-07 05:52:50

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output

The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input

 5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
 

Sample Output

 3 

题目大意:就是有两台机器A,B,分别由m和n种模式,初始时都在模式0,现在有k个工作,每一个工作都可以将A设置成模式i或将B设置成模式j,但每一次更换模式时机器不得不要重启,求完成所有工作的最小重启次数
输入数据的第一行有三个数据,分别代表工作数,A/B的模式数,当输入0时结束程序,接下来多行,每行的开始代表工作的序号,和完成该工作需将A/B设置的模式数,


ps:最小覆盖数=最大匹配数;
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int map[100][100];
int vis [100];
int link [100];
int n,m,k;
int dfs(int x)
{
int i ;
for (i=1;i<n;i++)
{
if (map[x][i]==1&&vis[i]==0 )
{
vis[i]=1;
if(link[i]==0||dfs(link[i]))
{
link[i]=x ;
return 1 ;
}
}
}
return 0;
}
int main()
{
int i,j;
int a,b,c;
while (~scanf("%d",&m))
{
if(m==0)
break;
scanf("%d %d",&n,&k);
memset(map,0,sizeof(map));
memset(link,0,sizeof(link));
while(k--)
{
scanf("%d %d %d",&a,&b,&c);
if ( b>0||c>0 )
map[b][c]=1 ;
}
int sum = 0 ;
for (i=1;i<m;i++)
{
memset(vis,0,sizeof(vis));
if (dfs(i))
sum++ ;
}
printf("%d\n",sum);
}
return 0;
}