Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!
import java.util.Scanner;
public class P2199 {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
int t=sc.nextInt();
while(t-->0){
long y=sc.nextLong();
double left=0;
double right=100;
if(y-f(left)<0||y-f(right)>0){
System.out.println("No solution!");
continue;
}else{
while(right-left>Math.pow(10, -6)){
double mid=(right+left)/2;
if(f(mid)>y){
right=mid;
}else {
left=mid;
}
}
System.out.printf("%.4f",right);
System.out.println();
}
}
}
public static double f(double x){
return 8*myPow(x,4) + 7*myPow(x,3) + 2*myPow(x,2) + 3*x + 6;
}
public static double myPow(double x,int i){
return Math.pow(x, i);
}
}