Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 16588 Accepted Submission(s): 7366Problem Description Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!
Author Redow
思路:简单的二分求解方程,但是有助于理解二分的含义。
代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MYDD 11030
using namespace std;
typedef double DO;//定义 DO 数据类型
DO fun(DO x) {
return 8.0*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
//8* X^4+ 7* X^3+ 2* X^2+ 3 * X +6= Y
int main() {
int t;
scanf("%d",&t);
while(t--) {
DO y;
scanf("%lf",&y);
if(y<fun(0)||fun(100)<y) {//函数的最大最小值
puts("No solution!");
continue;
}
int v=64;
DO turn=0.0,right=100.0,middle;
while(v--) {
middle=(turn+right)/2.0;
if(fun(middle)>y) {
right=middle;
} else {
turn=middle;
}
}
printf("%.4lf\n",middle);
}
return 0;
}