题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1071
The area
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7011 Accepted Submission(s): 4934
Note: The point P1 in the picture is the vertex of the parabola.
Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
Output For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
Sample Input 25.000000 5.0000000.000000 0.00000010.000000 0.00000010.000000 10.0000001.000000 1.00000014.000000 8.222222
Sample Output 33.3340.69HintFor float may be not accurate enough, please use double instead of float. 分析: 计算抛物线和直线方程, 代入求积分即可。 代码如下:
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <iostream>
#include <vector>
using namespace std;
typedef long long ll;
double x1,y11,k,b,a;
// 积分
double f(double x) // 不定积分值
{
return a*(x-x1)*(x-x1)*(x-x1)/3.0 - k/2*x*x+(y11-b)*x;
}
int main() {
double x2,y2,x3,y3;
int t;
cin>>t;
while(t--)
{
cin>>x1>>y11>>x2>>y2>>x3>>y3;
a=(y3-y11)/((x3-x1)*(x3-x1));
k=(y3-y2)/(x3-x2);
b=y3-k*x3;
printf("%.2f\n",f(x3)-f(x2)); // 定积分代入上下限
}
return 0;
}