数据结构实验之二叉树的建立与遍历
Time Limit: 1000MS Memory limit: 65536K
题目描述
已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。输入
输入一个长度小于50个字符的字符串。输出
输出共有4行:第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。
示例输入
abc,,de,g,,f,,,
示例输出
cbegdfacgefdba35
#include <iostream>
#include <algorithm>
using namespace std;
typedef struct node
{
char data;
struct node *lchild,*rchild;
} node, *tree;
int i;
int xiancreat(tree &t);
void visit(tree t);
void inorder(tree t);
void posorder(tree t);
int leave(tree t);
int deep(tree t);
int main()
{
tree t;
i=0;
xiancreat(t);
inorder(t);
cout<<endl;
posorder(t);
cout<<endl;
leave(t);
cout<<i<<endl;
cout<<deep(t)<<endl;
}
int xiancreat(tree &t)
{
char c;
cin>>c;
if(c==',')
t=NULL;
else
{
t=(tree)malloc(sizeof(node));
if(!t) exit(0);
t->data=c;
xiancreat(t->lchild);
xiancreat(t->rchild);
}
return 0;
}
void visit(tree t)
{
if(t->data!=',')
cout<<t->data;
}
void inorder(tree t)
{
if(t!=NULL)
{
inorder(t->lchild);
visit(t);
inorder(t->rchild);
}
}
void posorder(tree t)
{
if(t!=NULL)
{
posorder(t->lchild);
posorder(t->rchild);
visit(t);
}
}
int leave(tree t)
{
if(t!=NULL)
{
if(t->lchild==NULL&&t->rchild==NULL)
{
i++;
}
leave(t->lchild);
leave(t->rchild);
}
}
int deep(tree t)
{
int ld,rd;
if(t==NULL)
return 0;
else
{
ld=deep(t->lchild);
rd=deep(t->rchild);
}
if(ld>rd)
return ld+1;
else
return rd+1;
}