Problem Description
对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。
Input
输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。
Output
对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。
Example Input
4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0
Example Output
Yes
No
No
code:
#include <stdio.h>
//#include <string.h>
#include <stdlib.h>
int flag;
typedef struct BitNode
{
int data;
struct BitNode *lchild, *rchild;
}Bitree;
Bitree *creat(int x, Bitree *root)
{
if(!root)
{
root = new BitNode;
root->lchild = root->rchild = NULL;
root->data = x;
return root;
}
else
{
if(x>root->data)
{
root->rchild = creat(x, root->rchild);
}
else
{
root->lchild = creat(x, root->lchild);
}
}
return root;
}
void cmp(Bitree *root1, Bitree *root2)
{
if(!root1&&!root2) return;
else if(!root1||!root2)
{
flag = 0;
return;
}
else if(root1->data!=root2->data)
{
flag = 0;
return;
}
else
{
cmp(root1->lchild, root2->lchild);
cmp(root1->rchild, root2->rchild);
}
}
int main()
{
int n, l, i, x;
while(~scanf("%d", &n)&&n)
{
scanf("%d", &l);
Bitree *root1 = NULL;
for(i = 0;i<n;i++)
{
scanf("%d", &x);
root1 = creat(x, root1);
}
while(l--)
{
Bitree *root2 = NULL;
flag = 1;
for(i = 0;i<n;i++)
{
scanf("%d", &x);
root2 = creat(x, root2);
}
cmp(root1, root2);
if(!flag) printf("No\n");
else printf("Yes\n");
}
}
}
//#include <string.h>
#include <stdlib.h>
int flag;
typedef struct BitNode
{
int data;
struct BitNode *lchild, *rchild;
}Bitree;
Bitree *creat(int x, Bitree *root)
{
if(!root)
{
root = new BitNode;
root->lchild = root->rchild = NULL;
root->data = x;
return root;
}
else
{
if(x>root->data)
{
root->rchild = creat(x, root->rchild);
}
else
{
root->lchild = creat(x, root->lchild);
}
}
return root;
}
void cmp(Bitree *root1, Bitree *root2)
{
if(!root1&&!root2) return;
else if(!root1||!root2)
{
flag = 0;
return;
}
else if(root1->data!=root2->data)
{
flag = 0;
return;
}
else
{
cmp(root1->lchild, root2->lchild);
cmp(root1->rchild, root2->rchild);
}
}
int main()
{
int n, l, i, x;
while(~scanf("%d", &n)&&n)
{
scanf("%d", &l);
Bitree *root1 = NULL;
for(i = 0;i<n;i++)
{
scanf("%d", &x);
root1 = creat(x, root1);
}
while(l--)
{
Bitree *root2 = NULL;
flag = 1;
for(i = 0;i<n;i++)
{
scanf("%d", &x);
root2 = creat(x, root2);
}
cmp(root1, root2);
if(!flag) printf("No\n");
else printf("Yes\n");
}
}
}