数据结构实验之查找一:二叉排序树

时间:2022-01-07 10:32:01

数据结构实验之查找一:二叉排序树

Time Limit: 400MS Memory Limit: 65536KB Submit Statistic

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Example Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Example Output

Yes
No
No

#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>

using namespace std;

typedef struct node
{
int data;
node *l;
node *r;
}Tree;

Tree *creat(int key, Tree *root)
{
if(root==NULL)
{
root=new Tree;
root->l=NULL;
root->r=NULL;
root->data=key;
}
else
{
if(key<root->data)
root->l=creat(key, root->l);
else
root->r=creat(key, root->r);
}
return root;

}

int flag;

void judge(Tree *root1, Tree *root2)
{
if(root1&&root2)
{
if(root1->data==root2->data)
{
judge(root1->l, root2->l);
judge(root1->r, root2->r);
}
else
{
flag=0;
return;
}
}

}

int main()
{
ios::sync_with_stdio(false);
int n, m;
int a[11];
while(cin>>n&&n)
{
Tree *root1=NULL;
cin>>m;
for(int i=0;i<n;++i)
{
cin>>a[i];
root1=creat(a[i], root1);
}
while(m--)
{
int b[11];
Tree *root2=NULL;
for(int i=0;i<n;++i)
{
cin>>b[i];
root2=creat(b[i], root2);
}
flag=1;
judge(root1, root2);
if(flag)
cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
}
return 0;
}