hdu-5703 Desert(水题)

时间:2022-12-10 22:16:35

题目链接:

Desert

Time Limit: 2000/1000 MS (Java/Others)    

Memory Limit: 65535/32768 K (Java/Others)

Problem Description
A tourist gets lost in the desert with n liters of water. He drinks positive integer units of water each day.

Write a program to calculate how many different ways the tourist can drink up the water.

Input
The first line contains the number of test cases T(T≤10).
Next T lines contain the number n(1≤n≤1000000) for each test case.
Output
Output consists of T lines.
Each line contains the binary number which represents number of different ways to finish up the water specified in the test case.
Sample Input
1
3
Sample Output
100
题意:
n是多少个不同序列的和?
思路:
可以发现是2^(n-1)种;
AC代码:
#include <bits/stdc++.h>
/*
#include <iostream>
#include <queue>
#include <cmath>
#include <map>
#include <cstring>
#include <algorithm>
#include <cstdio>
*/
using namespace std;
#define Riep(n) for(int i=1;i<=n;i++)
#define Riop(n) for(int i=0;i<n;i++)
#define Rjep(n) for(int j=1;j<=n;j++)
#define Rjop(n) for(int j=0;j<n;j++)
#define mst(ss,b) memset(ss,b,sizeof(ss));
typedef long long LL;
const LL mod=1e9+;
const double PI=acos(-1.0);
const LL inf=1e18;
const int N=1e6+;
int n,q;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
n--;
printf("");
while(n--)printf("");
printf("\n");
}
return ;
}