本文版权归ljh2000和博客园共有,欢迎转载,但须保留此声明,并给出原文链接,谢谢合作。
本文作者:ljh2000
作者博客:http://www.cnblogs.com/ljh2000-jump/
转载请注明出处,侵权必究,保留最终解释权!
Description
Input
Output
Sample Input
1 2 1.5
2 1 1.5
1 3 3
2 3 1.5
3 4 1.5
1 4 1.5
Sample Output
HINT
样例解释
有意义的转换方式共4种:
1->4,消耗能量 1.5
1->2->1->4,消耗能量 4.5
1->3->4,消耗能量 4.5
1->2->3->4,消耗能量 4.5
显然最多只能完成其中的3种转换方式(选第一种方式,后三种方式仍选两个),即最多可以转换3份样本。
如果将 E=14.9 改为 E=15,则可以完成以上全部方式,答案变为 4。
数据规模
占总分不小于 10% 的数据满足 N <= 6,M<=15。
占总分不小于 20% 的数据满足 N <= 100,M<=300,E<=100且E和所有的ei均为整数(可以直接作为整型数字读入)。
所有数据满足 2 <= N <= 5000,1 <= M <= 200000,1<=E<=107,1<=ei<=E,E和所有的ei为实数。
Source
正解:A*算法
解题报告:
我这种蒟蒻到今天才想起要学A*算法QAQ
然而就是一个2分钟可以学完的内容...
考虑我们需要求前k短路,那么我们可以对我们当前的状态进行估价。
令H(S)=g(S)+f(S)表示估价函数,f表示已经产生的代价,这一部分显然是确定的。而g函数表示的是在当前状态S下,对于到达n的距离的估价,两者加起来就是当前状态下的估价函数值,表示一条路径的期望长度。
用小根堆堆维护这个H估计函数,依次从堆中取出拓展即可。A*算法的本质就是搜索...只不过加入了估价函数之后可以大大剪枝...这题必须写手写堆,不然会MLE...
//It is made by ljh2000
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
typedef long long LL;
const int MAXN = 5011;
const int MAXM = 200011;
int n,m,ecnt,first[MAXN],to[MAXM],next[MAXM],ans,top;
double w[MAXM],dis[MAXN],E;
//估价函数H,现有确定代价函数f
struct node{ double H,f; int id; }Top,tmp,q[1000011];
inline void link(int x,int y,double z){ next[++ecnt]=first[x]; first[x]=ecnt; to[ecnt]=y; w[ecnt]=z; }
namespace new_Graph{
int ecnt,first[MAXN],to[MAXM],next[MAXM]; double w[MAXM];
int dui[MAXM*10],head,tail; bool in[MAXN];
inline void link(int x,int y,double z){ next[++ecnt]=first[x]; first[x]=ecnt; to[ecnt]=y; w[ecnt]=z; }
inline void SPFA(){
for(int i=1;i<=n;i++) dis[i]=1e20;
head=tail=0; dis[n]=0; dui[++tail]=n; in[n]=1; int u;
while(head<tail) {
head++; u=dui[head]; in[u]=0;
for(int i=first[u];i;i=next[i]) {
int v=to[i];
if(dis[v]>dis[u]+w[i]) {
dis[v]=dis[u]+w[i];
if(!in[v]) {
dui[++tail]=v;
in[v]=1;
}
}
}
}
}
} inline int getint(){
int w=0,q=0; char c=getchar(); while((c<'0'||c>'9') && c!='-') c=getchar();
if(c=='-') q=1,c=getchar(); while (c>='0'&&c<='9') w=w*10+c-'0',c=getchar(); return q?-w:w;
}
inline node get_top(){ return q[1]; }
inline void pop(){
q[1]=q[top--]; int u=1,lson=2,rson=3,son;
while(lson<=top) {
son=lson; if(q[rson].H<q[lson].H) son=rson;
if(q[son].H>=q[u].H) break;
swap(q[son],q[u]);
u=son; lson=u<<1; rson=lson|1;
}
} inline void push(node t){
q[++top]=t; int u=top,fa=u>>1;
while(fa>0) {
if(q[u].H>=q[fa].H) break;
swap(q[u],q[fa]);
u=fa; fa=u>>1;
}
} inline void Astar(){
tmp.H=dis[1]; tmp.f=0; tmp.id=1; push(tmp); int u;
while(top>0) {
Top=get_top(); pop(); u=Top.id;
if(u==n) {
if(E<Top.f) break;
E-=Top.f; ans++;
}
for(int i=first[u];i;i=next[i]) {
int v=to[i];
tmp.f=Top.f+w[i];
tmp.H=dis[v]+tmp.f;
tmp.id=v;
push(tmp);
}
}
} inline void work(){
n=getint(); m=getint(); scanf("%lf",&E); int x,y; double z;
for(int i=1;i<=m;i++) {
x=getint(); y=getint(); scanf("%lf",&z);
link(x,y,z);
new_Graph::link(y,x,z);
}
new_Graph::SPFA();
Astar();
printf("%d",ans);
} int main()
{
work();
return 0;
}