网格中矩形的个数

时间:2022-11-05 15:40:34

网格中矩形的个数

题目链接:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=84562#problem/N

    题目:

Description

给你一个高为n ,宽为m列的网格,计算出这个网格中有多少个矩形,下图为高为2,宽为4的网格. 
网格中矩形的个数
 

Input

第一行输入一个t, 表示有t组数据,然后每行输入n,m,分别表示网格的高和宽 ( n < 100 , m < 100).  

Output

每行输出网格中有多少个矩形. 

Sample Input

21 22 4  

Sample Output

330                              分析:找出规律即可  每个n*m的网格中矩形的个数为1加到n乘以1加到m。   
#include<iostream>
using namespace std;
int main()
{
int t,n,m,x,y;
cin
>>t;
while(t--)
{
cin
>>n>>m;
x
=(1+n)*n/2;
y
=(1+m)*m/2;
cout
<<x*y<<endl;

}
return 0;
}