Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
代码:
#include<stdio.h>
#include<iostream>
using namespace std;
int max(int a,int b){
return a>b?a:b;
}
int main(){
int a,b,t=0;
int c[100000];
int f[100000];
int p[100000];
cin>>a;
while(a--){
t++;
cin>>b;
for(int i=0;i<b;i++){
cin>>c[i];
p[i]=i;
}
f[0]=c[0];
for(int i=1;i<b;i++){
f[i]=max(c[i],f[i-1]+c[i]);
if(f[i]==c[i])p[i]=i;
if(f[i]==c[i]+f[i-1])p[i]=p[i-1];
}
int Max=f[0];
int s=p[0];
int e=0;
for(int i=1;i<b;i++){
if(Max<f[i]){
Max=f[i];
s=p[i];
e=i;
}
}
cout<<"Case "<<t<<":"<<endl<<Max<<" "<<s+1<<" "<<e+1<<endl;
if(a)cout<<endl;
}
return 0;
}