题目 1738: 排序

时间:2024-12-17 22:25:51

题目 1738: 排序
时间限制: 2s 内存限制: 96MB 提交: 14351 解决: 3477
题目描述
对输入的n个数进行排序并输出。

输入格式
输入的第一行包括一个整数n(1<=n<=100)。 接下来的一行包括n个整数。

输出格式
可能有多组测试数据,对于每组数据,将排序后的n个整数输出,每个数后面都有一个空格。
每组测试数据的结果占一行

样例输入
5
5 4 3 1 2
样例输出
1 2 3 4 5

#include <bits/stdc++.h>
using namespace std;
const int N = 101;

int main() {
	
	int n;
	int array[N];
	int temp = 0;
	
	while(cin >> n && n >= 1 && n <= 100){
	
	for(int i=1; i<=n; i++) {
		cin >> array[i];
	}
	
	// 冒泡排序
	for(int i=1; i<=n; i++) {
		for(int j=1; j<=n-i; j++) {
			if(array[j] > array[j+1]) {
				temp = array[j + 1];
				array[j + 1] = array[j];
				array[j] = temp;
			}
		}
	} 
	
	for(int i=1; i<=n; i++) {
		cout << array[i] << " ";
	}
	cout << endl;
	//	cout << array[n];
	}
	
	
	return 0;
}

https://www.runoob.com/w3cnote/bubble-sort.html
冒泡排序原理的讲解