
Navigation Nightmare
Description
Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look
something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): F1 --- (13) ---- F6 --- (9) ----- F3 | | (3) | | (7) F4 --- (20) -------- F2 | | | (2) F5 | F7 Being an ASCII diagram, it is not precisely to scale, of course. FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. Input * Line 1: Two space-separated integers: N and M * Lines 2..M+1: Each line contains four space-separated entities, F1, F2, L, and D that describe a road. F1 and F2 are numbers of two farms connected by a road, L is its length, and D is a character that is either 'N', 'E', 'S', or 'W' giving the direction of the road from F1 to F2. * Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's queries * Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob and contains three space-separated integers: F1, F2, and I. F1 and F2 are numbers of the two farms in the query and I is the index (1 <= I <= M) in the data after which Bob asks the query. Data index 1 is on line 2 of the input data, and so on. Output * Lines 1..K: One integer per line, the response to each of Bob's queries. Each line should contain either a distance measurement or -1, if it is impossible to determine the appropriate distance. Sample Input 7 6 Sample Output 13 Hint
At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown. At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. Source |
题目大意:
给定n个城市,m条边告诉你城市间的相对距离,接下来q组询问,问你在第几条边加入后两城市的距离。
解题思路:
用离线处理。再用并查集维护每一个城市到父亲城市的距离。
解题思路:
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std; const int maxn=41000; struct edge{
int u,v,dis;
char ch;
}e[maxn]; struct node{
int u,v,cnt,id,ans;
}a[maxn]; int n,m,q;
int father[maxn],offx[maxn],offy[maxn]; bool cmp1(node x,node y){
return x.cnt<y.cnt;
} bool cmp2(node x,node y){
return x.id<y.id;
} void input(){
scanf("%d%d",&n,&m);
for(int i=0;i<=n;i++){
father[i]=i;
offx[i]=offy[i]=0;
}
for(int i=0;i<m;i++){
scanf("%d%d%d %c",&e[i].u,&e[i].v,&e[i].dis,&e[i].ch);
}
scanf("%d",&q);
for(int i=0;i<q;i++){
scanf("%d%d%d",&a[i].u,&a[i].v,&a[i].cnt);
a[i].id=i;
}
sort(a,a+q,cmp1);
} int find(int x){
if(father[x]!=x){
int tmp=father[x];
father[x]=find(father[x]);
offx[x]+=offx[tmp];
offy[x]+=offy[tmp];
}
return father[x];
} void combine(int x,int y,int dis,char ch){
int fx=find(x);
int fy=find(y);
father[fy]=fx;
int offx0=offx[x]-offx[y];
int offy0=offy[x]-offy[y];
//cout<<fy<<"->"<<fx;
if(ch=='N') offy0+=dis;
else if(ch=='S') offy0-=dis;
else if(ch=='E') offx0+=dis;
else offx0-=dis;
//cout<<":("<<offx[fy]<<","<<offy[fy]<<")"<<endl;
offx[fy]=offx0;
offy[fy]=offy0;
//cout<<":("<<offx[fy]<<","<<offy[fy]<<")"<<endl;
} void solve(){
int k=0;
for(int i=0;i<q;i++){
for(;k<a[i].cnt;k++){
if(find(e[k].u)!=find(e[k].v)){
combine(e[k].u,e[k].v,e[k].dis,e[k].ch);
}
}
if( find(a[i].u)!=find(a[i].v) ) a[i].ans=-1;
else{
int ans=abs(offx[a[i].u]-offx[a[i].v])+abs(offy[a[i].u]-offy[a[i].v]);
a[i].ans=ans;
}
}
sort(a,a+q,cmp2);
for(int i=0;i<q;i++){
printf("%d\n",a[i].ans);
}
} int main(){
input();
solve();
return 0;
}
版权声明:本文博客原创文章。博客,未经同意,不得转载。