HDU 2008 数字统计

时间:2022-02-26 00:13:46

号码值统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 53462    Accepted Submission(s): 27366

Problem Description
统计给定的n个数中,负数、零和正数的个数。
 
Input
输入数据有多组,每组占一行,每行的第一个数是整数n(n<100),表示须要统计的数值的个数,然后是n个实数;假设n=0,则表示输入结束,该行不做处理。
 
Output
对于每组输入数据。输出一行a,b和c。分别表示给定的数据中负数、零和正数的个数。
 
Sample Input
6 0 1 2 3 -1 0
5 1 2 3 4 0.5
0
 
Sample Output
1 2 3
0 0 5
 


注意:不能用数组存数,由于输入的数有可能是小数。要一个一个的推断


#include<stdio.h>
int main()
{
int n;
while(scanf("%d",&n),n)
{
int i,j,a=0,b=0,c=0;
double s;
for(i=0;i<n;i++)
{
scanf("%lf",&s);
{
if(s<0) a++;
else if(s==0) b++;
else if(s>0) c++;
}
}
printf("%d %d %d",a,b,c);
printf("\n");
}
return 0;
}

版权声明:本文博主原创文章,博客,未经同意不得转载。