hdu 2222 Keywords Search AC自动机模板题

时间:2022-08-19 20:03:55

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40414    Accepted Submission(s): 12885


Problem Description In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 
Input First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 
Output Print how many keywords are contained in the description.  
Sample Input
1
5
she
he
say
shr
her
yasherhs
 
Sample Output
3
 哎,,看了很长时间的AC自动机理论,,再看的模板代码,最后才对AC自动机有点透彻的了解。
AC自动机理论:http://blog.csdn.net/niushuai666/article/details/7002823
代码:
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
#define SIZE 1000100
using namespace std ;

struct Trie{
int count ;
Trie *fail ;
Trie *next[26] ;
Trie()
{
for(int i = 0 ; i < 26 ; ++i)
next[i] = NULL ;
fail = NULL ;
count = 0 ;
}
} *root ;
char des[SIZE] ;
void insert(char ch[])
{
int len = strlen(ch) ;
Trie *t = root ;
for(int i = 0 ; i < len ; ++i)
{
if(t->next[ch[i]-'a'] == NULL)
{
t->next[ch[i]-'a'] = new Trie() ;
}
t = t->next[ch[i]-'a'] ;
}
t->count++ ;
}

void bfs()
{
queue<Trie*> que ;
que.push(root) ;
while(!que.empty())
{
Trie *t = que.front() ;
que.pop() ;
for(int i = 0 ; i < 26 ; ++i)
{
if(t->next[i] != NULL)
{
if(t == root)
t->next[i]->fail = root ;
else
{
Trie *p = t->fail ;
while( p )
{
if(p->next[i])
{
t->next[i]->fail = p->next[i] ;
break ;
}
p = p->fail ;
}
if(p == NULL)
t->next[i]->fail = root ;
}
que.push(t->next[i]) ;
}
}
}
}

int query(char str[])
{
int sum = 0 , i = 0;
Trie *now = root ;
while(str[i])
{
int pos = str[i]-'a' ;
while(now->next[pos] == NULL && now != root)
{
now = now->fail ;
}
now = now->next[pos] ;
if(!now)
now = root ;
Trie *temp = now ;
while(temp != root)
{
if(temp->count>=0)
{
sum += temp->count ;
temp->count = -1 ;
}
else break ;

temp = temp->fail ;
}
++i ;
}
return sum ;
}
void del(Trie *t)
{
for(int i = 0 ; i < 26 ; ++i)
{
if(t->next[i])
del(t->next[i]) ;
}
free(t) ;
}
int main()
{
int t ;
scanf("%d",&t) ;
while(t--)
{
root = new Trie() ;
int n ;
scanf("%d",&n);
getchar() ;
for(int i = 0 ; i < n ; ++i)
{
char str[100] ;
gets(str) ;
insert(str) ;
}
bfs() ;
gets(des) ;
int ans = query(des) ;
printf("%d\n",ans) ;
del(root) ;
}
return 0 ;
}

与君共勉