C++:泛型编程 map(查询成绩)

时间:2022-01-24 04:22:45

泛型编程 map(查询成绩)

Time Limit(Common/Java):1000MS/3000MS Memory Limit:65536KByte
Total Submit:47 Accepted:34

Description

输入每个学生的学号、及三门功课的成绩。再根据学号查询学生的总分。

Input

第1行是学生人数n。

第2行–第n+1行为输入每个学生的学号、及三门功课的成绩。

第n+2行是查询次数m。

第n+3–第n+m-1行是要查询学生的学号。

Output

输出学生的总分。如果学号不存在,输出“Not”

Sample Input

4
1001 70 80 90
1002 60 70 80
1003 80 90 70
1004 70 85 85
2
1002
1005

Sample Output

210
Not


代码块:

#include<iostream>
#include<map>
using namespace std;
int main()
{
map<int,int> m1;
int t,n,m,i,s;
cin>>t;
while(t--)
{
cin>>n;
i=3;
m1[n]=0;
while(i)
{
cin>>m;
m1[n]+=m;
i--;
}}
cin>>t;
while(t--)
{
cin>>n;
if(m1.find(n)!=m1.end())
cout<<m1[n]<<endl;
else
cout<<"Not"<<endl;
}
return 0;
}