poj 3267 The Cow Lexicon (DP)

时间:2022-08-07 03:41:25

题目链接:http://poj.org/problem?id=3267

The Cow Lexicon
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10403   Accepted: 4983

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

Source

[Submit]   [Go Back]   [Status]   [Discuss]

poj 3267 The Cow Lexicon (DP)Home Page   poj 3267 The Cow Lexicon (DP)Go Back  poj 3267 The Cow Lexicon (DP)To top



题意:给你一个字符串,和一个字典,问删除几个字符使得剩下的字符有意义

解析:dp[i]从最后到 i 的最小删除字符的个数,dp[i] = min(dp[i], dp[k] + k - i - L[j])    区间 [i, k - 1] , k是能匹配到字典中单词的位置,

            i是开始位置,L[j],第 j +1单词串的长度

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>
#include<map>
#include<vector>
#include<stack>
#define N 309
using namespace std;
const int INF = 0x3f3f3f3f;
int dp[N], L[N<<1];
char s[N], dic[N<<1][N];

int main()
{
    int len, w;
    scanf("%d%d", &w, &len);
    scanf("%s", s);
    for(int i = 0; i < w; i++)
    {
        scanf("%s", dic[i]);
        L[i] = strlen(dic[i]);
    }
    dp[len] = 0;
    for(int i = len - 1; i >= 0; i--)
    {
        dp[i] = dp[i + 1] + 1;
        for(int j = 0 ; j < w; j++)
        {
            if(len - i < L[j]) continue;
            int kk, k;
            for(k = i, kk = 0; k < len && kk < L[j]; k++)
            {
                if(dic[j][kk] == s[k]) kk++;
            }
            if(kk == L[j]) dp[i] = min(dp[i], dp[k] + k - i - L[j]);
        }
    }
    printf("%d\n", dp[0]);
    return 0;
}