PAT 1081 检查密码(15) (代码+思路)

时间:2023-01-29 03:57:25

1081 检查密码(15 分)

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

思路:核心:完美密码--数字,字母必须出现,密码长度大于6,除点(.)之外的非法字符不能出现 。

这里用4个值进行逻辑判断:digit(数字),alpha(字母),point(点),other(非法字符)。

#include<iostream>
#include<string>
using namespace std;
int main()
{
int n;
cin>>n;
string s;
getchar();
int digit=0,alpha=0,point=0,other=0;
while(n--){
getline(cin,s);
if(s.length()<6){
cout<<"Your password is tai duan le."<<endl;
}
else {
for(int i=0;i<s.length();i++){
if(isdigit(s[i]))
digit=1;
else if(isalpha(s[i]))
alpha=1;
else if(s[i]=='.')
point=1;
else
other=1;
}
if(other) //出现非法字符
cout<<"Your password is tai luan le."<<endl;
else if(alpha&&digit==0) //有字母,没数字
cout<<"Your password needs shu zi."<<endl;
else if(digit&&alpha==0) //有数字,没字母
cout<<"Your password needs zi mu."<<endl;
else //格式正确
cout<<"Your password is wan mei."<<endl;
}
digit=0,alpha=0,point=0,other=0;
}
return 0;
}