Wolf and Rabbit(gcd)

时间:2021-03-14 00:18:21

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5922    Accepted Submission(s):
2972

点我

Problem Description
There is a hill with n holes around. The holes are
signed from 0 to n-1.

Wolf and Rabbit(gcd)

A rabbit must
hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The
first hole he get into is the one signed with 0. Then he will get into the hole
every m holes. For example, m=2 and n=6, the wolf will get into the holes which
are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she
will survive. So we call these holes the safe holes.

 
Input
The input starts with a positive integer P which
indicates the number of test cases. Then on the following P lines,each line
consists 2 positive integer m and n(0<m,n<2147483648).
 
Output
For each input m n, if safe holes exist, you should
output "YES", else output "NO" in a single line.
 
Sample Input
2
1 2
2 2
 
Sample Output
NO
YES
如果不互质则会循环下去,互质则会存在位置不能到达
 #include <iostream>
#include <cstring>
using namespace std;
#define LL long long
LL gcd(LL x,LL y)
{
if(x<y)
return gcd(y,x);
if(y==)
return x;
return gcd(y,x%y);
}
int main()
{
LL n,m;
int k;
cin>>k;
while(k--)
{
cin>>m>>n;
LL p=gcd(m,n);
// cout<<p<<endl;
if(p==)
cout<<"NO\n";
else
cout<<"YES\n";
}
return ;
}