HDU 1077Catching Fish(简单计算几何)

时间:2022-01-26 22:56:10

Catching Fish

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1113    Accepted Submission(s): 411

Problem Description
Ignatius likes catching fish very much. He has a fishnet whose shape is a circle of radius one. Now he is about to use his fishnet to catch fish. All the fish are in the lake, and we assume all the fish will not move when Ignatius catching them. Now Ignatius wants to know how many fish he can catch by using his fishnet once. We assume that the fish can be regard as a point. So now the problem is how many points can be enclosed by a circle of radius one.

Note: If a fish is just on the border of the fishnet, it is also caught by Ignatius.

 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case starts with a positive integer N(1<=N<=300) which indicate the number of fish in the lake. Then N lines follow. Each line contains two floating-point number X and Y (0.0<=X,Y<=10.0). You may assume no two fish will at the same point, and no two fish are closer than 0.0001, no two fish in a test case are approximately at a distance of 2.0. In other words, if the distance between the fish and the centre of the fishnet is smaller 1.0001, we say the fish is also caught.

 
Output
For each test case, you should output the maximum number of fish Ignatius can catch by using his fishnet once.

 
Sample Input
4
3
6.47634 7.69628
5.16828 4.79915
6.69533 6.20378
6
7.15296 4.08328
6.50827 2.69466
5.91219 3.86661
5.29853 4.16097
6.10838 3.46039
6.34060 2.41599
8
7.90650 4.01746
4.10998 4.18354
4.67289 4.01887
6.33885 4.28388
4.98106 3.82728
5.12379 5.16473
7.84664 4.67693
4.02776 3.87990
20
6.65128 5.47490
6.42743 6.26189
6.35864 4.61611
6.59020 4.54228
4.43967 5.70059
4.38226 5.70536
5.50755 6.18163
7.41971 6.13668
6.71936 3.04496
5.61832 4.23857
5.99424 4.29328
5.60961 4.32998
6.82242 5.79683
5.44693 3.82724
6.70906 3.65736
7.89087 5.68000
6.23300 4.59530
5.92401 4.92329
6.24168 3.81389
6.22671 3.62210
 
Sample Output
2
5
5
11
 
Author
Ignatius.L
 


题目大意:给你n个点的横纵坐标,问你用一个单位圆,最多能使得多少点在圆内,包括圆上的点。


      解题思路:开始比较迷茫,不知道用什么方法来解,后来觉得可以枚举,但又想不清楚怎么枚举。这样,我们每次找两个点,看能否根据这两点确定一个单位圆,然后看这个圆能包含其它多少点在这个圆内!

       题目地址:Catching Fish

开始是用数组写的,时间直接2s开外了!
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdio>
using namespace std;
int n;
struct node
{
double x;
double y;
};
node a[305]; double dis(node p1,node p2)
{
return sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y));
} int cal(int p1,int p2)
{
node t1,t2,t3,t4;
t1=a[p1],t2=a[p2];
double s,tmp,xx,yy;
tmp=dis(t1,t2);
s=tmp/2.0;
s=sqrt(1.0-s*s); //s为圆心到t1,t2弦长的距离
int ans1=0,ans2=0,i;
xx=(t1.y-t2.y)/tmp;
yy=(t2.x-t1.x)/tmp; //(xx,yy)相当于与弦长垂直的单位法向量
t3.x=(t1.x+t2.x)/2.0,t3.y=(t1.y+t2.y)/2.0;
t4.x=t3.x+s*xx,t4.y=t3.y+s*yy; //t4为圆心
for(i=0;i<n;i++)
{
if(dis(t4,a[i])<1.0001)
ans1++;
}
t4.x=t3.x-s*xx,t4.y=t3.y-s*yy; //t4为圆心
for(i=0;i<n;i++)
{
if(dis(t4,a[i])<1.0001)
ans2++;
}
return ans1>ans2?ans1:ans2;
} int main()
{
int i,j;
int tes;
scanf("%d",&tes); while(tes--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%lf%lf",&a[i].x,&a[i].y);
int num;
int res=1;
for(i=0;i<n;i++)
for(j=i+1;j<n;j++)
{
if(dis(a[i],a[j])<2.0001)
{
num=cal(i,j);
if(num>res) res=num;
}
} printf("%d\n",res);
}
return 0;
} //2406MS
后来改用数组写了,时间终于降到了1s内,Best solutions里面还是有很多两三百ms的,Orz!!
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstdio>
using namespace std;
int n;
double a[305][2]; double dis(double *b1,double *b2)
{
return sqrt((b1[0]-b2[0])*(b1[0]-b2[0])+(b1[1]-b2[1])*(b1[1]-b2[1]));
} int cal(int p1,int p2)
{
double t1[2],t2[2],t3[2],t4[2];
t1[0]=a[p1][0],t1[1]=a[p1][1],t2[0]=a[p2][0],t2[1]=a[p2][1];
double s,tmp,xx,yy;
tmp=dis(t1,t2);
s=tmp/2.0;
s=sqrt(1.0-s*s); //s为圆心到t1,t2弦长的距离
int ans1=0,ans2=0,i;
xx=(t1[1]-t2[1])/tmp;
yy=(t2[0]-t1[0])/tmp; //(xx,yy)相当于与弦长垂直的单位法向量
t3[0]=(t1[0]+t2[0])/2.0,t3[1]=(t1[1]+t2[1])/2.0;
t4[0]=t3[0]+s*xx,t4[1]=t3[1]+s*yy; //t4为圆心
for(i=0;i<n;i++)
{
if(dis(t4,a[i])<1.0001)
ans1++;
}
t4[0]=t3[0]-s*xx,t4[1]=t3[1]-s*yy; //t4为圆心
for(i=0;i<n;i++)
{
if(dis(t4,a[i])<1.0001)
ans2++;
}
return ans1>ans2?ans1:ans2;
} int main()
{
int i,j;
int tes;
scanf("%d",&tes); while(tes--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%lf%lf",&a[i][0],&a[i][1]);
int num;
int res=1;
for(i=0;i<n;i++)
for(j=i+1;j<n;j++)
{
if(dis(a[i],a[j])<2.0001)
{
num=cal(i,j);
if(num>res) res=num;
}
} printf("%d\n",res);
}
return 0;
} //984MS G++

HDU 1077Catching Fish(简单计算几何)的更多相关文章

  1. HDU 4643 GSM 简单计算几何

    今天比赛的时候略坑, admin告诉我询问Q的个数不超过n^2, 赛后敲了个 O(Q*m^3)的复杂度,但这个复杂度常数比较低,可能在除以个小常数, 300ms过了,真心无语,数据应该水了吧,比赛的时 ...

  2. HDU 2085 核反应堆 --- 简单递推

    HDU 2085 核反应堆 /* HDU 2085 核反应堆 --- 简单递推 */ #include <cstdio> ; long long a[N], b[N]; //a表示高能质点 ...

  3. HDU 5130 Signal Interference&lpar;计算几何 &plus; 模板&rpar;

    HDU 5130 Signal Interference(计算几何 + 模板) 题目链接http://acm.hdu.edu.cn/showproblem.php?pid=5130 Descripti ...

  4. ●POJ 1556 The Doors(简单计算几何&plus;最短路)

    ●赘述题目 10*10的房间内,有竖着的一些墙(不超过18个).问从点(0,5)到(10,5)的最短路. 按照输入样例,输入的连续5个数,x,y1,y2,y3,y4,表示(x,0--y1),(x,y2 ...

  5. 2018&period;07&period;04 POJ 2398 Toy Storage(二分&plus;简单计算几何)

    Toy Storage Time Limit: 1000MS Memory Limit: 65536K Description Mom and dad have a problem: their ch ...

  6. Least Common Multiple &lpar;HDU - 1019&rpar; 【简单数论】【LCM】【欧几里得辗转相除法】

    Least Common Multiple (HDU - 1019) [简单数论][LCM][欧几里得辗转相除法] 标签: 入门讲座题解 数论 题目描述 The least common multip ...

  7. 七夕节 &lpar;HDU - 1215&rpar; 【简单数论】【找因数】

    七夕节 (HDU - 1215) [简单数论][找因数] 标签: 入门讲座题解 数论 题目描述 七夕节那天,月老来到数字王国,他在城门上贴了一张告示,并且和数字王国的人们说:"你们想知道你们 ...

  8. &lbrack;HDU 4082&rsqb; Hou Yi&&num;39&semi;s secret &lpar;简单计算几何&rpar;

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4082 题目大意: 给你n个点,问能最多构成多少个相似三角形. 用余弦定理,计算三个角度,然后暴力数有多 ...

  9. HDU 4617 Weapon &lpar;简单三维计算几何,异面直线距离&rpar;

    Weapon Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)Total Subm ...

随机推荐

  1. 【基础】利用thrift实现一个非阻塞带有回调机制的客户端

    假设读者对thrift有一定了解. 客户端有时需要非阻塞的去发送请求,给定服务端一个请求,要求其返回一个计算结果.但是客户端不想等待服务端处理完,而是想发送完这个指令后自己去做其他事情,当结果返回时自 ...

  2. C&plus;&plus;中public&comma;protected&comma;private派生类继承问题和访问权限问题

    C++中public,protected,private派生类继承问题和访问权限问题 当一个子类从父类继承时,父类的所有成员成为子类的成员,此时对父类成员的访问状态由继承时使用的继承限定符决定. 1. ...

  3. ansible自动化运维工具的安装与使用

    运行环境 centOS6.6 ansible ansible的功能还是比较多的,博主只用它在集群上进行批量部署软件和维护的功能,其他不多做研究,有需要的话这篇文章会慢慢补充. ansible特点 轻量 ...

  4. Sql Server REPLACE函数的使用&semi;SQL中 patindex函数的用法

    Sql Server REPLACE函数的使用 REPLACE用第三个表达式替换第一个字符串表达式中出现的所有第二个给定字符串表达式. 语法REPLACE ( ''string_replace1'' ...

  5. JavaScript面向对象,闭包内存图,闭包和作用域

    var i = 10; function test(){ var j; i=20; //未定义 function test(){ j='hello'; } console.log(test()); / ...

  6. 数据结构中,几种树的结构表示方法(C语言实现)

    //***************************************** //树的多种结构定义 //***************************************** # ...

  7. Linux系统zookeeper环境搭建(单机、伪分布式、分布式)

    本人现在对zookeeper的环境搭建做一个总结,一般zookeeper的安装部署可以有三种模式,单机模式.伪分布式和分布式,这三种模式在什么时候应用具体看大家的使用场景,如果你只有一台机器且只是想自 ...

  8. iOS scrollView中嵌套多个tabeleView处理方案

    项目中经常会有这样的需求,scrollView有个头部,当scrollView滚动的时候头部也跟着滚动,同时头部还有一个tab会锁定在某个位置,scrollView中可以放很多不同的view,这些vi ...

  9. C&plus;&plus;练习 &vert; 运算符重载练习

    #include <iostream> #include <cmath> #include <cstring> #include <iomanip> u ...

  10. os&period;fork&lpar;&rpar;

    ret = os.fork() if ret == 0: child_suite # 子进程代码 else: parent_suite # 父进程代码 Python中的fork() 函数可以获得系统中 ...