HDOJ2070 Fibbonacci Number

时间:2023-02-20 10:58:56


Fibbonacci Number


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26638    Accepted Submission(s): 12205


Problem Description


Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.


 



Input


Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.


 



Output


Print out the answer in a single line for each test case.


 



Sample Input


3 4 5 -1


 



Sample Output


Hint

Note:


you can use 64bit integer: __int64

 


import java.util.Scanner;

public class Main{
private static Scanner scanner;
public static void main(String[] args) {
scanner = new Scanner(System.in);
while(scanner.hasNext()){
int n= scanner.nextInt();
if(n == -1){
break;
}

//打表
long arr[] = new long[51];
arr[0] = 0;
arr[1] = 1;
for (int i = 2; i < arr.length; i++) {
arr[i] = arr[i-1]+arr[i-2];
}
//输出
System.out.println(arr[n]);
}
}
}