POJ 2155 Matrix (二维线段树)

时间:2022-02-05 13:31:06
Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 17226   Accepted: 6461

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

这题二维线段树也可以做。

二维线段树需要  给一个矩形加一个值

查询单个的值。

加值的时候直接加一个块。

查询的时候把这个点以及和这个点相关的都累加起来。

数据结构写法多样啊,重在理解

 /* ***********************************************
Author :kuangbin
Created Time :2014/5/23 23:08:19
File Name :E:\2014ACM\专题学习\数据结构\二维线段树\POJ2155.cpp
************************************************ */ #include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const int MAXN = ;
struct Nodey
{
int l,r;
int val;
};
int n;
int locx[MAXN],locy[MAXN];
struct Nodex
{
int l,r;
Nodey sty[MAXN*];
void build(int i,int _l,int _r)
{
sty[i].l = _l;
sty[i].r = _r;
sty[i].val = ;
if(_l == _r)
{
locy[_l] = i;
return;
}
int mid = (_l + _r)>>;
build(i<<,_l,mid);
build((i<<)|,mid+,_r);
}
void add(int i,int _l,int _r,int val)
{
if(sty[i].l == _l && sty[i].r == _r)
{
sty[i].val += val;
return;
}
int mid = (sty[i].l + sty[i].r)>>;
if(_r <= mid)add(i<<,_l,_r,val);
else if(_l > mid)add((i<<)|,_l,_r,val);
else
{
add(i<<,_l,mid,val);
add((i<<)|,mid+,_r,val);
}
}
}stx[MAXN*];
void build(int i,int l,int r)
{
stx[i].l = l;
stx[i].r = r;
stx[i].build(,,n);
if(l == r)
{
locx[l] = i;
return;
}
int mid = (l+r)>>;
build(i<<,l,mid);
build((i<<)|,mid+,r);
}
void add(int i,int x1,int x2,int y1,int y2,int val)
{
if(stx[i].l == x1 && stx[i].r == x2)
{
stx[i].add(,y1,y2,val);
return;
}
int mid = (stx[i].l + stx[i].r)/;
if(x2 <= mid)add(i<<,x1,x2,y1,y2,val);
else if(x1 > mid)add((i<<)|,x1,x2,y1,y2,val);
else
{
add(i<<,x1,mid,y1,y2,val);
add((i<<)|,mid+,x2,y1,y2,val);
}
}
int sum(int x,int y)
{
int ret = ;
for(int i = locx[x];i;i >>= )
for(int j = locy[y];j;j >>= )
ret += stx[i].sty[j].val;
return ret;
} int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int T;
scanf("%d",&T);
while(T--)
{
int q;
scanf("%d%d",&n,&q);
build(,,n);
char op[];
int x1,x2,y1,y2;
while(q--)
{
scanf("%s",op);
if(op[] == 'C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
add(,x1,x2,y1,y2,);
}
else
{
scanf("%d%d",&x1,&y1);
if(sum(x1,y1)% == )printf("0\n");
else printf("1\n");
}
}
if(T)printf("\n");
}
return ;
}