![Bitset[HDU2051] Bitset[HDU2051]](https://image.shishitao.com:8440/aHR0cHM6Ly9ia3FzaW1nLmlrYWZhbi5jb20vdXBsb2FkL2NoYXRncHQtcy5wbmc%2FIQ%3D%3D.png?!?w=700&webp=1)
Bitset
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10007 Accepted Submission(s): 7749
Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1
2
3
Sample Output
1
10
11
Author
8600 && xhd
Source
校庆杯Warm Up
Recommend
linle
除2倒取余数
#include<stdio.h>
int main()
{
int p[50],x,i;
while (scanf("%d",&x)!=EOF)
{
int cnt=0;
while (x)
{
p[cnt++]=x&1;
x>>=1;
}
for (i=cnt-1;i>=0;i--) printf("%d",p[i]);
printf("\n");
}
return 0;
}