Pixel density
Time Limit: 1000MS Memory limit: 65536K
题目描述
Pixels per inch (PPI) or pixel density is a measurement of the resolution of devices in various contexts; typically computer displays, image scanners, and digital camera image sensors. Note, the unit is not square inches. Good quality photographs
usually require 300 pixels per inch when printed. When the PPI is more than 300(phone), we call it retina screen. Sunnypiggy like the retina screen very much.
But you know it is expensive for Sunnypiggy and Sunnypiggy’s own smart phone isn’t like that.
I tell you how to calculate the PPI. First we must know how big the mobile phone’s screen is. Then we get the resolution (Hp*Wp) about it. After that we calculate the diagonal resolution in pixels (Dp) and divided by diagonal size in inches. Now you get the
answer.
Maybe you knew it, but Sunnypiggy’s math is very bad and he wants you to help him to calculate the pixel density of all the electronic products he dreamed.
输入
First you will get an integer T which means the number of test cases, and then Sunnypiggy will tell you the name and type of the electronic products. And you know, Sunnypiggy is a careless boy and some data aren’t standard, just like 04.00 inches
or 0800*0480.
输出
Output the answers to Sunnypiggy just like the sample output. Maybe it is not a phone. Sunnypiggy like such a form, although it seems no use. The result should be rounded to 2 decimal places. When it has no screen (0.0 inches) that we define
the answer is 0.00(PPI).
示例输入
2iPhone 4S 3.5 inches 960*640 PHONE
The new iPad 0009.7 inches 2048*1536 PAD
示例输出
Case 1: The phone of iPhone 4S's PPI is 329.65.
Case 2: The pad of The new iPad's PPI is 263.92.
提示
来源
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
typedef long long LL;
using namespace std;
int main()
{
int T;
cin>>T;
string mess;
char siz[1000];
char x[1000];
char y[1000];
char name[1000];
char type[1000];
int sizp,xp,yp;
int pos;
int pos_t;
double inch;
int px,py;
int cas=0;
getchar();
while(T--)
{
cas++;
getline(cin,mess);
pos=mess.find("inches");
pos_t=pos-1;
while(mess[pos_t]==' ') pos_t--;
sizp=0;
while(mess[pos_t]!=' ')
{
siz[sizp]=mess[pos_t];
pos_t--;
sizp++;
}
char tmp[1000];
for(int i=0; i<=sizp; i++)
tmp[sizp-i-1]=siz[i];
tmp[sizp]='\0';
sscanf(tmp,"%lf",&inch);
while(mess[pos_t]==' ') pos_t--;
for(int i=0; i<=pos_t; i++)
{
name[i]=mess[i];
}
name[pos_t+1]='\0';
pos_t=pos+6;
while(mess[pos_t]==' ') pos_t++;
xp=0;
while(mess[pos_t]!='*')
{
x[xp]=mess[pos_t];
xp++;
pos_t++;
}
x[xp]='\0';
sscanf(x,"%d",&px);
pos_t++;
yp=0;
while(mess[pos_t]!=' ')
{
y[yp]=mess[pos_t];
yp++;
pos_t++;
}
y[yp]='\0';
sscanf(y,"%d",&py);
while(mess[pos_t]==' ') pos_t++;
for(int i=pos_t; i<mess.size(); i++)
{
if(mess[i]>='A'&&mess[i]<='Z')
type[i-pos_t]=mess[i]+32;
else type[i-pos_t]=mess[i];
}
type[mess.size()-pos_t]='\0';
double ans;
if(inch!=0)ans=sqrt(px*px+py*py)/inch;
else ans=0.00;
printf("Case %d: The %s of %s's PPI is %.2f.\n",cas,type,name,ans);
}
return 0;
}